A Bit Too Protected

I’ve been trying to get my new iPAQ working with my home wireless network with no success.

I had a chat online with the HP technical support, who walked me through the standard scripted stuff with no luck. The wireless card definitely works because if I switch security to either off or WEP-only it works fine. For the iPAQ 5550 you need updated firmware and drivers to support WPA encryption (as per my current network config) and these have been applied.

After much digging, there is a suspicion that the problem lies with my Linksys WAG54G2 wireless router. In the wireless security configuration, setting it to “WPA” mode provides just one encryption option: “TKIP or AES”. I’m no WiFi security expert, but TKIP is a software-only thing (basically some wrappering around basic WEP functionality), while AES is hardware-supported functionality.

The theory behind the Linksys option is that devices which support AES can use that encryption method, while others can default back to TKIP. As a result of AES requiring hardware, this isn’t supported with my (relatively old) iPAQ. Unfortunately there seems to be a problem with the iPAQ talking to the router correctly with this proprietary system.

After much Googling, I discovered two things:

  1. There have been lots of people struggling to get Windows Mobile devices to talk to WPA networks
  2. This has been discussed at length on the Linksys forums, most specifically in this thread.

I also spoke to the Linksys technical support people, who were rubbish and couldn’t give me any advice.

It looks like my best hope at present is either to swap my current router for another one (I’m not that desperate for wireless connectivity), or hope that it is addressed in a future firmware update. Unfortunately the Linksys helpdesk person couldn’t tell me when this would be, so it looks like I’m stuck for now.